htmlArea

A directory of browser-based WYSIWYG editors

  MAIN
INDEX
SEARCH
POSTS
WHO'S
ONLINE
LOG
IN

Home: htmlArea 2: htmlArea 2 & 3 archive (read only): htmlArea v2.0:
Turn Off HTML Formatting in Source Code?


The htmlArea 2 & 3 editors have been discontinued.

We've made these forums available as a read-only reference and knowledge-base for people using or developing editors based on htmlArea 2 or 3.

Anyone who is interested in taking over version 2 or 3 is free to do so. All we ask is that you choose a new name that doesn't have "htmlarea" in it to avoid confusion with this site. We'll even give you a link in the directory to make it easier for people to find you. If you are developing or hosting an htmlArea based-editor under a new name, please submit it to our directory.

 


adalby
New User

Sep 10, 2004, 11:03 PM

Post #1 of 4 (1981 views)
Shortcut
Turn Off HTML Formatting in Source Code? Can't Post

This Editor is awesome but I have a problem. I'm using this editor to upload new content to my web pages and also I can go back into the editor to change text at times when needed. I have this set up already with no problem, Here's the problem:

When I go back to edit these text blocks it automatically puts in <br> tags and gets my code all messed up. Is there a way to turn off the html formatting in the source code to just be straight lines of code that doesn't get messed up with <br> and <p> tags when I upload them a second time. When I change text a second time and upload I get double the amounts of <br> tags.

Thanks in advanced,

Aaron


Luis
Veteran

Sep 11, 2004, 12:42 AM

Post #2 of 4 (1975 views)
Shortcut
Re: [adalby] Turn Off HTML Formatting in Source Code? [In reply to] Can't Post

Hi adalby:

I think it's not HTMLArea what causes the problem but the script you use to retrieve your content. I guess your script must be replacing \n with <P> and \r with <BR>.

If you modified a script which originally worked with a normal textarea to use it with HTMLArea instead, it's 99% likely to be the problem.

Greetings.


Don't give up!!
http://webstationone.com/test/htmlarea


adalby
New User

Sep 11, 2004, 9:20 AM

Post #3 of 4 (1966 views)
Shortcut
Re: [Luis] Turn Off HTML Formatting in Source Code? [In reply to] Can't Post

Luis, thanks for the reply but I think its within the htmlArea .js script. The reason I know this is when I paste in the code from notepad into the source code view in your script and then change back to the WYSIWYG and then back to the source code view it has been changed or formatted somehow. (Like spaces and <tbody> tags have been inserted in. In this example my text never goes through my othe cgi script.



Here's an example of what I'm pasting in that is good, since the code is altogether in a stright line, condensed the editor doesn't throw in <br> tags. The results look great until I try to edit these text entries. You can view that in the second example below:

<TABLE cellSpacing=0 cellPadding=1 width="90%" border=0><TBODY><TR vAlign=top><TD colSpan=2><FONT face=Arial size=-1 align="center"><B>Schedule of Events</B></FONT></TD></TR><TR vAlign=top><TD align=left><FONT face=Arial size=-1>&nbsp;</FONT></TD><TD align=right><FONT face=Arial size=-1>&nbsp;</FONT></TD></TR><TR vAlign=top><TD align=left><FONT face=Arial size=-1><B><U>Friday, October1</B></FONT></U></TD><TD align=right><FONT face=Arial size=-1>&nbsp;</FONT></TD></TR><TR vAlign=top><TD align=left><FONT face=Arial size=-1>3:00 PM - 8:00 pm</FONT></TD><TD align=left><FONT face=Arial size=-1>Bonfire </FONT></TD></TR></table>





Here's the bad output example of the change that is made be htmlarea when I switch back to source code view(and what is uploaded) and screws up my code and adds <br> tags. If I were to edit this twice, now with all the spaces there would be double the amount of <br> tags(4 tags for each line and so on each time):

<TABLE cellSpacing=0 cellPadding=1 width="90%" border=0><BR><BR>
<TBODY><BR><BR>
<TR vAlign=top><BR><BR>
<TD colSpan=2><FONT face=Arial size=-1><B>Schedule of
<BR><BR>Events</B></FONT></TD></TR><BR><BR>
<TR vAlign=top><BR><BR>
<TD align=left><FONT face=Arial size=-1>&nbsp;</FONT></TD><BR><BR>
<TD align=right><FONT face=Arial size=-1>&nbsp;</FONT></TD></TR><BR><BR>
<TR vAlign=top><BR><BR>
<TD align=left><FONT face=Arial size=-1><B><U>Friday, October
<BR><BR>1</B></FONT></U></TD><BR><BR>
<TD align=right><FONT face=Arial size=-1>&nbsp;</FONT></TD></TR><BR><BR>
<TR vAlign=top><BR><BR>
<TD align=left><FONT face=Arial size=-1>3:00 PM - 8:00 pm</FONT></TD><BR><BR>
<TD align=left><FONT face=Arial size=-1>Bonfire </FONT></TD></TR><BR><BR></TBODY></TABLE>



Thanks Luis for the help,

Aaron


(This post was edited by adalby on Sep 11, 2004, 9:24 AM)


Luis
Veteran

Sep 12, 2004, 12:49 AM

Post #4 of 4 (1944 views)
Shortcut
Re: [adalby] Turn Off HTML Formatting in Source Code? [In reply to] Can't Post

Hi adalby:

This forum is for V2. and htmlarea.js is for V3.0.

As I don't know V3.0, I cannot guide you in the right direction about what's making the <BR>'s get inserted and of course, to provide a solution. I guess it's a similar problem as I stated in my previous reply.

As per the <TBODY> tag, it's not htmlarea, but IE. There are many things that the editable plataform does by itself: i.e. The <tbody> tags, absolute links and img src, and a lot of etceteras. I ignore if mozilla does the same.


Don't give up!!
http://webstationone.com/test/htmlarea

 
 
 


Search for (options)