htmlArea

A directory of browser-based WYSIWYG editors

  MAIN
INDEX
SEARCH
POSTS
WHO'S
ONLINE
LOG
IN

Home: htmlArea 2: htmlArea 2 & 3 archive (read only): htmlArea v2.0:
htmlarea not appearing until page is refreshed


The htmlArea 2 & 3 editors have been discontinued.

We've made these forums available as a read-only reference and knowledge-base for people using or developing editors based on htmlArea 2 or 3.

Anyone who is interested in taking over version 2 or 3 is free to do so. All we ask is that you choose a new name that doesn't have "htmlarea" in it to avoid confusion with this site. We'll even give you a link in the directory to make it easier for people to find you. If you are developing or hosting an htmlArea based-editor under a new name, please submit it to our directory.

 


aerris
New User

Oct 29, 2004, 3:39 AM

Post #1 of 2 (2575 views)
Shortcut
htmlarea not appearing until page is refreshed Can't Post

Hello,

I have put HTMLarea into a php/mysql database admin page, the htmlarea being applied to a textarea correspoding to a TEXT datatype in the mysql database.

When i click "update" to change the contents of the TEXT datatype, the form opens up, but the textarea is just a normal text area with no toolbar and displays the content in HTML form.

If i press F5 and click "retry" it calls the page again and loads the form again with the textarea displaying the htmlarea toolbar and the contents as formatted html.

how can i make the toolbar appear the first time the page with the form on it loads? so i dont have to refresh the page to see it.

it all works fine, excpet the initial loading of the toolbar. as soon as i refresh i can change the content and click submit, and it updates the TEXT in the mysql database.

any ideas how to fix this?

Thanks

aerris


aerris
New User

Oct 29, 2004, 4:15 AM

Post #2 of 2 (2571 views)
Shortcut
Re: [aerris] htmlarea not appearing until page is refreshed [In reply to] Can't Post

actually - have now fixed this.



i made sure this:




Code
  </FORM>  
<script language="JavaScript1.2" defer>
editor_generate(\'lr_page_text\');
</script>

was after the closing form tag and put some backslashes in as it thought the editor_generate thing was the end of my php echo.



all works now. top job htmlarea


(This post was edited by aerris on Oct 29, 2004, 4:15 AM)

 
 
 


Search for (options)