htmlArea

A directory of browser-based WYSIWYG editors

  MAIN
INDEX
SEARCH
POSTS
WHO'S
ONLINE
LOG
IN

Home: htmlArea 3 (beta): htmlArea 2 & 3 archive (read only): htmlArea v3.0 - Discussion:
HTMLArea 3.0-RC1


The htmlArea 2 & 3 editors have been discontinued.

We've made these forums available as a read-only reference and knowledge-base for people using or developing editors based on htmlArea 2 or 3.

Anyone who is interested in taking over version 2 or 3 is free to do so. All we ask is that you choose a new name that doesn't have "htmlarea" in it to avoid confusion with this site. We'll even give you a link in the directory to make it easier for people to find you. If you are developing or hosting an htmlArea based-editor under a new name, please submit it to our directory.

First page Previous page 1 2 3 4 5 6 Next page Last page  View All


arokia
Novice

Sep 21, 2004, 1:46 AM

Post #126 of 138 (18825 views)
Shortcut
Re: [mishoo] HTMLArea 3.0-RC1 [In reply to] Can't Post

hi mate,

Javascript functions are not working.
Javascript functions are inside Head tag only.
While editing the file through mozilla browser the html is encoded that is

Before editing:

Code
function MM_swapImgRestore() { //v3.0 
var i,x,a=document.MM_sr; for(i=0;a&&i<a.length&&(x=a)&&x.oSrc;i++) x.src=x.oSrc;
}


After editing:

Code
function MM_swapImgRestore() { //v3.0 
var i,x,a=document.MM_sr; for(i=0;a&amp;&amp;i&lt;a.length&amp;&amp;(x=a)&amp;&amp;x.oSrc;i++) x.src=x.oSrc;
}


I have attached a sample file to be edited.

Kindly provide me solution for the above problem.

Thanking in advance,
Arokia
Attachments: liaison.htm (11.7 KB)


Jochie
Novice

Sep 22, 2004, 2:09 AM

Post #127 of 138 (18779 views)
Shortcut
Re: [mishoo] HTMLArea 3.0-RC1 [In reply to] Can't Post

hello,

i have the same problem: i've put 2 textfields and 1 textarea in a form. the textarea gets replaced by the HTMLArea. So far, everything goes well. But when i click on the submitbutton, the program reports an error saying the textarea has no value (ie. is empty). does anybody know how to fix this?

jochem


StevenTN
New User

Nov 1, 2004, 1:25 AM

Post #128 of 138 (18070 views)
Shortcut
Re: [valio] Popups Security problem [In reply to] Can't Post


In Reply To
When try to open popups (Firefox 0.9.2/IE6.0.2900.2180/WinXP SP2), I receive:

Error: [Exception... "'Permission denied to get property Window.addEventListener' when calling method: [nsIDOMEventListener::handleEvent]" nsresult: "0x8057001e (NS_ERROR_XPC_JS_THREW_STRING)" location: "<unknown>" data: no]

And then popup window can't communicate with opener:

Error: opener.Dialog._return is not a function
Source File:
http://localhost/test/js/htmlarea/popups/popup.js
Line: 98

I am confused, exactly the same code in reference.html works fine. No other JS in page, only php session is started.



I am getting the exact same error (only with Mozilla 1.0PR1). I also get an error in IE6, only it tells me that it's in the HTML file for the popup itself.

We use HTMLArea 3.0 for our editors, so that they can input links, images, etc., and format the text accordingly. Since we are a critical news site, any help/input would be greatly appreciated.


(This post was edited by StevenTN on Nov 1, 2004, 1:27 AM)


thanh
Novice

Nov 10, 2004, 8:45 PM

Post #129 of 138 (17590 views)
Shortcut
Re: [mishoo] HTMLArea 3.0-RC1 [In reply to] Can't Post

Hi Mishoo and everybody,

It seems very empty that I couldn't download the HTMLArea 3.0-RC1 package. I have tried to choose all of mirror to download but I still meet the problem that the link automatically jumps to the HTMLArea 3.0-RC1.htm page. Could you guide me how to download it?

Thanks,


(This post was edited by thanh on Nov 11, 2004, 12:58 AM)


randys
New User

Nov 28, 2004, 11:43 AM

Post #130 of 138 (16719 views)
Shortcut
Re: [mishoo] HTMLArea 3.0-RC1 [In reply to] Can't Post

The values for radios and checkboxes seem to get omitted in this version.


bobbyshen
New User

Dec 5, 2004, 5:25 AM

Post #131 of 138 (16368 views)
Shortcut
Re: [mishoo] HTMLArea 3.0-RC1 [In reply to] Can't Post

Two bugs:
"redo" and "undo" button do not work, the same as beta version.
When "body" element is removed by using context-menu, the textarea field will not accept any input content.


hschaefer
New User

Dec 9, 2004, 7:57 AM

Post #132 of 138 (16150 views)
Shortcut
Re: [bobbyshen] HTMLArea 3.0-RC1 [In reply to] Can't Post

I'm writing a php portal and need htmlarea inside an iframe.

Doing any change, for example switching into html and back to wysiwyg and clicking bold, firefox throwhs the error:

[Exception... "Component returned failure code: 0xc1f30001 (NS_ERROR_NOT_INITIALZED)
[nsIDOMNSHTMLDocument.execCommand]" nsresult "0xc1f30001
(NS_ERROR_NOT_INITIALIZED)" location "JS frame ::
.../htmlarea.js :: anonymous :: line 1867" data: no]
by execCommand(bold);

The problems seems to be in a false handle to the iframe dom document. i don't know if this is a firefox bug or not handled by htmlarea.

You can reproduce this by using a simple html file with an iframe tag like <iframe src="fully-loaded.html" style="padding:10px">. If you switch using "Toggle HTML Source" and click any Button like bold you will get the error inside firefox.

I'm using the latest cvs snapshot from 2004-12-09 with htmlarea.js v1.95

Any workarounds?


(This post was edited by hschaefer on Dec 9, 2004, 9:37 AM)


wwaldrup
New User

Dec 14, 2004, 8:26 AM

Post #133 of 138 (15868 views)
Shortcut
Re: [mishoo] HTMLArea 3.0-RC1 [In reply to] Can't Post

Where can I get the new release?


overdose
New User

Dec 20, 2004, 7:23 AM

Post #134 of 138 (15569 views)
Shortcut
Re: [mishoo] HTMLArea 3.0-RC1 [In reply to] Can't Post

Hi Mishoo,
When i load the 'table properties', 'row properties' and 'cell properties' pop-ups from the TableOperations menu they default to the wrong size and i can't see the 'OK' and 'Cancel' buttons.

I also get javascript errors saying 'element.align' is null or not an object on line 314, and sometimes the pop-ups open and are blank.

Do you also get these errors? I get them with every htmlarea with the TableOperations plugin, including your new version 3.0 example on: http://www.dynarch.com/demos/htmlarea/examples/table-operations.html
Can you help please?


riege
New User

Dec 23, 2004, 10:12 AM

Post #135 of 138 (15297 views)
Shortcut
Re: [mishoo] HTMLArea 3.0-RC1 [In reply to] Can't Post

Hi,

great tool!

Just i found some bugs and i wonder when the next release will be published?

thanks

Peter


LeeR
New User

Dec 24, 2004, 7:38 AM

Post #136 of 138 (15247 views)
Shortcut
Re: [riege] HTMLArea 3.0-RC1 [In reply to] Can't Post

Hi, I would love to say that this thing is a great tool, but that wouldn't be true would it.

It is advertised as being Firefox 1.0 compatible but yet it hardly works at all on my machine.
For example..
1) it flickers constantly on every mouse or keypress.
2) the dialog boxes don't get focus when they popup.
3) the buttons don't work on the popup windows when you finally do give em focus
4) the html that it was creating was erroneous so i had to 'fix' that myself!

all in all it's pretty useless to a firefox user in it's current state.

Now I am willing to admit that I can't expect a perfect product as it is only a BETA release, however I have seen posts dated back in july highlighting some of the bugs which I have mentioned. What exactly have the developers been doing for the last 6 months?? Not trying to get it working in Mozilla obviously! So maybe you should remove the "mozilla compatible" tag because its a lie as far as I can see.


rhsoftware
Novice

Dec 31, 2004, 6:23 PM

Post #137 of 138 (14676 views)
Shortcut
Where are problems with firefox ? [In reply to] Can't Post

Sorry but that is not true
We use HTMLArea since one year in our cms based on the old beta

* The Code is 100 % W3C-Conform
* It works perfect since all Firefox-Versions and Mozilla >= 1.4
* The focus-troubles are not really so bad

we use it on mac, windows and linux and all our partners use firefox/mozilla because MSIE makes bad html and makes many errors

dont understand your troubles !


LeeR
New User

Jan 4, 2005, 3:09 AM

Post #138 of 138 (14447 views)
Shortcut
Re: [rhsoftware] Where are problems with firefox ? [In reply to] Can't Post

Hmmm.

Well I just downloaded HtmlArea 3 Beta RC1 to another location to try again from the beginning and everything does seem to be OK, it is not flickering, the code seems fine, the only problem seems to be when you click OK on the links popup, although it adds the link it doesn't close the popup.

Maybe I was in a strange mood when I downloaded it the first time. I dunno what I could have done different!

UPDATE.. I just realised what's causing the flickering.
I am using DIVs to position the HtmlArea on the page.
That causes flickering in Firefozx. IE on the otherhand does not have a problem.


(This post was edited by LeeR on Jan 4, 2005, 3:17 AM)

First page Previous page 1 2 3 4 5 6 Next page Last page  View All
 
 


Search for (options)