htmlArea

A directory of browser-based WYSIWYG editors

  MAIN
INDEX
SEARCH
POSTS
WHO'S
ONLINE
LOG
IN

Home: htmlArea 3 (beta): htmlArea 2 & 3 archive (read only): htmlArea v3.0 - Support Requests:
Doesn't work at all


The htmlArea 2 & 3 editors have been discontinued.

We've made these forums available as a read-only reference and knowledge-base for people using or developing editors based on htmlArea 2 or 3.

Anyone who is interested in taking over version 2 or 3 is free to do so. All we ask is that you choose a new name that doesn't have "htmlarea" in it to avoid confusion with this site. We'll even give you a link in the directory to make it easier for people to find you. If you are developing or hosting an htmlArea based-editor under a new name, please submit it to our directory.

 


elmonty
New User

Feb 11, 2005, 1:41 PM

Post #1 of 3 (27554 views)
Shortcut
Doesn't work at all Can't Post

I dl'ed RC3 and am using the following code:


Code
<script type="text/javascript"> 
_editor_url = "/htmlarea/";
_editor_lang = "en";
</script>
<script type="text/javascript" src="/htmlarea/htmlarea.js"></script>
<script type="text/javascript">
var editor = new HTMLArea.replace("ta");
</script>
</head>

<body bgcolor="#FFFFFF" text="#000000">
<div style="width:800px" align="center"><b>Current Mailing:</b></div>
<form name="form1" method="post" action="maileredit.php">
<textarea id="ta" name="ta" cols="80" rows="20">
bla bla bla
</textarea>
<div align="center" style="width:800px">
<input type="submit" name="Save" value="Save">
<input type="button" name="Cancel" value="Cancel">
</div>
</form>


When I view the page from the server, I just see the textarea.


reg
Novice

Feb 11, 2005, 1:57 PM

Post #2 of 3 (27550 views)
Shortcut
Re: [elmonty] Doesn't work at all [In reply to] Can't Post

Would it help if the script to replace TA with htmlarea came after the definition of TA; I seem to have all my code doing that although I don't know whether that's an accident or by design

hth

Reg


elmonty
New User

Feb 13, 2005, 9:10 AM

Post #3 of 3 (27515 views)
Shortcut
Re: [reg] Doesn't work at all [In reply to] Can't Post

If I put it after the HTML, I get an error message that I have to call HTMLArea.init() first. Even if I *do* call HTMLArea.init(), I get the same error.

This thing is crap.

 
 
 


Search for (options)