htmlArea

A directory of browser-based WYSIWYG editors

  MAIN
INDEX
SEARCH
POSTS
WHO'S
ONLINE
LOG
IN

Home: htmlArea 2: htmlArea 2 & 3 archive (read only): htmlArea v2.0 - Add-Ons:
Image Manager + Editor for v3.0 RC1


The htmlArea 2 & 3 editors have been discontinued.

We've made these forums available as a read-only reference and knowledge-base for people using or developing editors based on htmlArea 2 or 3.

Anyone who is interested in taking over version 2 or 3 is free to do so. All we ask is that you choose a new name that doesn't have "htmlarea" in it to avoid confusion with this site. We'll even give you a link in the directory to make it easier for people to find you. If you are developing or hosting an htmlArea based-editor under a new name, please submit it to our directory.

 


wei
User

Apr 4, 2004, 11:28 PM

Post #1 of 7 (6203 views)
Shortcut
Image Manager + Editor for v3.0 RC1 Can't Post

Hi all

Ok, I have been slack and have only recently updated the Image Manger. Whats new:

1) Updated for v3.0 RC1, it is now a plugin, no need to modify any code in HTMLArea, just copy/drop the ImageManager directory into the plugins directory of HTMLArea.

2) Refactor the manager code, half of them started from scratch. It is an on going process :)

3) Documentation, it is an on going process as well :D

4) Simpler to configure (I hope), and fixed many ugly, buggy, silly codes. Your help is needed in finding them, and for me to solve it.

5) And added some simple security measures.

Ok, there seem to be alot of problems in getting the thumbnail generation to work in the past. Lets get a few things clear,

GD = No Gif (most likely, unless you are using old GD)

Safe Mode ON = GD = No Gif (unless you can execute command line executables, you can not use NetPBM, ImageMagick extension may be possible).

Safe Mode OFF = NetPBM, don't use GD, get NetPBM binaries, available for both linux and windows.

If you have problems in getting the manager to start or work, please let me know.

The new code can be downloaded from sourceforget.net, http://www.zhuo.org/htmlarea/

Cheers,

Wei


vigosan
Novice

Apr 8, 2004, 6:02 AM

Post #2 of 7 (6074 views)
Shortcut
Re: [wei] Image Manager + Editor for v3.0 RC1 [In reply to] Can't Post

Hollo I'm Vicent G (vigosan).

Thank you for your new version, Image manager is great (HTMLArea too), but I can't see thumbnails ;)

I combined your version with the version of AlRashid that support File manager (http://alrashid.klokan.sk/insFile/htmlareademo/).

You can dowload the merge HTMLArea in http://www.freepgs.com/vgozalbes

Thank you, and how can I solve the problem of thumbnails ?


Priet
New User

Apr 18, 2004, 8:40 AM

Post #3 of 7 (5868 views)
Shortcut
Re: [vigosan] Image Manager + Editor for v3.0 RC1 [In reply to] Can't Post

First of all: Thanks for this great plugin!

But I've troubles getting it working. When I load the plugin and use the 'image' button of the HTMLArea the old Image dialog is showed.

Here's my code:


Code
  <script type="text/javascript"> 
_editor_url = "htmlarea/";
_editor_lang = "nl";
</script>

<!-- load the main HTMLArea file -->
<script type="text/javascript" src="htmlarea/htmlarea.js"></script>
<script type="text/javascript">
HTMLArea.loadPlugin("ContextMenu");
HTMLArea.loadPlugin("TableOperations");
//load the ImageManage + Editor plug-in
HTMLArea.loadPlugin("ImageManager");
</script>

<textarea id='artikel' style='height: 600px; width: 90%;'>Sample text</textarea>

<script type="text/javascript">
var editor = new HTMLArea("artikel");
editor.registerPlugin(ContextMenu);
editor.registerPlugin(TableOperations);
editor.generate();
</script>


Unfortunately, this won't work Frown

I don't know what's causing the problem, maybe one the experts know what I'm doing wrong? The other two plugins works just fine.

tia :)
You know what they say: 'If you see a light at the end of a wormhole, it's probably a photon torpedo![/]i'


novocaine
Novice

Apr 18, 2004, 1:11 PM

Post #4 of 7 (5859 views)
Shortcut
Re: [Priet] Image Manager + Editor for v3.0 RC1 [In reply to] Can't Post

I am using AlRashid's file manager and have problems in Firefox/Mozilla when creating a link.
The code is

editor.insertNodeAtSelection(alink);

The problem is, that after I insert a link and start typing in text, the text get's linked too.
How can I prevent Mozilla from doing this?

Thanks,
novocaine


wei
User

Apr 20, 2004, 8:52 PM

Post #5 of 7 (5814 views)
Shortcut
Re: [Priet] Image Manager + Editor for v3.0 RC1 [In reply to] Can't Post

Does the following work? It seem to work on FireFox 0.8 and IE6


Code
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" 
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<title>Test of Image Manager + Other plugins</title>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<style type="text/css">
/*<![CDATA[*/
<!--
.textarea { height: 30em; width: 80%; }
-->
/*]]>*/
</style>
<script type="text/javascript">
//<![CDATA[
_editor_url = "htmlarea/";
_editor_lang = "nl";
//]]>
</script><!-- load the main HTMLArea file -->
<script type="text/javascript" src="htmlarea/htmlarea.js">
</script>
<script type="text/javascript">
//<![CDATA[
HTMLArea.loadPlugin("ContextMenu");
HTMLArea.loadPlugin("TableOperations");
HTMLArea.loadPlugin("ImageManager");

initdocument = function ()
{
var editor = new HTMLArea("editor");
editor.registerPlugin(ContextMenu);
editor.registerPlugin(TableOperations);
editor.generate();
}

function addEvent(obj, evType, fn)
{
if (obj.addEventListener) { obj.addEventListener(evType, fn, true); return true; }
else if (obj.attachEvent) { var r = obj.attachEvent("on"+evType, fn); return r; }
else { return false; }
}

addEvent(window, 'load', initdocument);
//]]>
</script>
</head>
<body>
<div><textarea id="editor" class="textarea" rows="10" cols="40"></textarea></div>
</body>
</html>



martekbiz
Novice

May 5, 2004, 7:27 AM

Post #6 of 7 (5658 views)
Shortcut
Re: [wei] Image Manager + Editor for v3.0 RC1 [In reply to] Can't Post

Hi wei,

I'm hoping you might be able to help me.

When I use your ImageManager, it loads fine and whatnot, I can create directories - which is cool - but I cannot see any images in my directory.

What I mean is... the placeholder in ImageManager shows that there is an image there and lists the filename but the thumbnail doesn't show an image. It shows an "X".

What am I doing wrong and what cna I do to get this working?

Any help/ideas?

Thanks so much.

Aaron


DragónCL
Novice

Jun 25, 2004, 3:41 PM

Post #7 of 7 (5156 views)
Shortcut
Re: [wei] Image Manager + Editor for v3.0 RC1 [In reply to] Can't Post

Hi, wei!

A great job, congratulations!

Can you help me how to integrate your script with the htmlarea as you did it on your demo?

In second hand, I'm trying your script, I have allready configure correctly the config.php file, BUT when I tryed to put to work the stuff, nothing happens. The button opens a null page, with nothing on it, why??? I really don't understand Unsure.

I'm using Apache, with php al mysql ... and Win XP.

Thanks,

Ricardo

 
 
 


Search for (options)