htmlArea

A directory of browser-based WYSIWYG editors

  MAIN
INDEX
SEARCH
POSTS
WHO'S
ONLINE
LOG
IN

Home: htmlArea 2: htmlArea 2 & 3 archive (read only): htmlArea v2.0 - Add-Ons:
See the ultimate Word cleaner. Amazing!!


The htmlArea 2 & 3 editors have been discontinued.

We've made these forums available as a read-only reference and knowledge-base for people using or developing editors based on htmlArea 2 or 3.

Anyone who is interested in taking over version 2 or 3 is free to do so. All we ask is that you choose a new name that doesn't have "htmlarea" in it to avoid confusion with this site. We'll even give you a link in the directory to make it easier for people to find you. If you are developing or hosting an htmlArea based-editor under a new name, please submit it to our directory.

First page Previous page 1 2 3 4 5 6 7 Next page Last page  View All


Rorrah
Novice

Jul 23, 2003, 7:03 PM

Post #51 of 169 (6896 views)
Shortcut
Re: [Luis] See the ultimate Word cleaner. Amazing!! [In reply to] Can't Post

The longer I look at this code the more my brain tries to dribble out my ear. Can anyone tell me how to put the word cleaner into the V3.0 version of HTMLArea?

Thanks


Luis
Veteran

Jul 23, 2003, 8:25 PM

Post #52 of 169 (6893 views)
Shortcut
Re: [Rorrah] See the ultimate Word cleaner. Amazing!! [In reply to] Can't Post

Hi Rorrah:

This code works with V2.3 only. Check in V3 Forum. I know there is some work around there.


Don't give up!!
http://webstationone.com/test/htmlarea


Rorrah
Novice

Jul 23, 2003, 9:12 PM

Post #53 of 169 (6889 views)
Shortcut
Re: [Luis] See the ultimate Word cleaner. Amazing!! [In reply to] Can't Post

I looked...I swear....I failed.

Ah well...thanks tho


wahooka27
New User

Jul 29, 2003, 3:14 PM

Post #54 of 169 (6836 views)
Shortcut
Re: [Rorrah] See the ultimate Word cleaner. Amazing!! [In reply to] Can't Post

hi luis-

this sounds like an awesome addon, but i cant seem to get your sample page to work. when i paste from word into your editor its great, but i see opening a word document is also an option. i couldn't get it to work though. it gives me an error 'document.body' is null or not an object.

does this feature work or are you planning on implementing at some later point? thanks for the awesome addon


Luis
Veteran

Jul 29, 2003, 3:23 PM

Post #55 of 169 (6832 views)
Shortcut
Re: [wahooka27] See the ultimate Word cleaner. Amazing!! [In reply to] Can't Post

Hi Wahooka27:

You need some settings in your computer to enable ActiveX:

instructions are in post #3 of this page:
http://www.interactivetools.com/forum/gforum.cgi?post=14813

Greetings!


Don't give up!!
http://webstationone.com/test/htmlarea


wahooka27
New User

Jul 30, 2003, 8:54 AM

Post #56 of 169 (6805 views)
Shortcut
Re: [Luis] See the ultimate Word cleaner. Amazing!! [In reply to] Can't Post

great. got it working thanks for the help and the great, great addon to an already very cool editor.

i have one other problem that maybe you could help me with. my htmlArea stores itself in a mysql db and when i create and add something in htmlArea and add it to the db, it works great.

but when i try to edit it, an odd thing happens. "Internet Explorer cannot open the Internet site http://mysite/editfield.php Operation Aborted" but if i click back after getting the error, the field is filled in and works. like say i get the error, click back and make a change and click "Edit" it works. so it seems like there is a problem intially loading the saved html code and loading it into the editor. why it works when i click back doesn't make too much sense...

also i should note, this problem is only with stuff i either pasted in from word or opened directly from word which makes me think it might be an issue with a certain tag or something, but the word cleanup works great so i cant figure it out.

do you or anyone have any idea why i could be having this problem? i sure could use the help
thanks once again!


(This post was edited by wahooka27 on Jul 30, 2003, 8:58 AM)


wahooka27
New User

Aug 1, 2003, 1:42 PM

Post #57 of 169 (6763 views)
Shortcut
Re: [wahooka27] See the ultimate Word cleaner. Amazing!! [In reply to] Can't Post

did some more investigation and i found a post that helped me out.

http://www.interactivetools.com/forum/gforum.cgi?post=8609

basically for some reason the code like this:

<script language="JavaScript1.2" defer>
editor_generate('customcontracts');

has to come after your form where you have a textarea. so after you close your form like " </form> " then put that javascript. i am pretty sure this has fixed it for me at least. thanks for the help editi


(This post was edited by wahooka27 on Aug 1, 2003, 1:43 PM)


siadmin
Novice

Aug 2, 2003, 4:02 AM

Post #58 of 169 (6751 views)
Shortcut
Re: [wahooka27] See the ultimate Word cleaner. Amazing!! [In reply to] Can't Post

Hiya, this is a rocking application, have been looking for something like this for a long time then found the original htmlArea then stumbled across this......... excellent work man.

Got a question for you well while I am here Sly

I am using ColdFusion to handle the forms and writting them to a mysql database..... everything works fine with the Word cleaner function apart from when I paste a document with a ' (apostrophe) the apostrophe turns into 3 boxes. The preview shows that everything is fine, just when I recall the information from the database it seems to play up. Looking at the field directly in the database it shows ’

Any help would be greatly appreciated.


QUIET! I can't hear you and the little voice in my head at the same time. Crazy


Luis
Veteran

Aug 2, 2003, 4:27 AM

Post #59 of 169 (6746 views)
Shortcut
Re: [siadmin] See the ultimate Word cleaner. Amazing!! [In reply to] Can't Post

Hi siadmin:

Try putting this line at the end of the function:

unclean = unclean.replace(/’/gi, '\'');


Don't give up!!
http://webstationone.com/test/htmlarea


siadmin
Novice

Aug 2, 2003, 4:42 AM

Post #60 of 169 (6744 views)
Shortcut
Re: [Luis] See the ultimate Word cleaner. Amazing!! [In reply to] Can't Post

Hiya Luis,

That didn't seem to make any difference......... if I manually go through the document pasted and change called apostrophes then it seems to work perfectly.

The apostrophe that appears in the textarea is different to the one if you were to type in the apostrophe.

Will see this works:

<pasted from word> the childs parent/guardian

<changed within textarea> the child's parent/guardian


QUIET! I can't hear you and the little voice in my head at the same time. Crazy


Luis
Veteran

Aug 2, 2003, 4:47 AM

Post #61 of 169 (6740 views)
Shortcut
Re: [siadmin] See the ultimate Word cleaner. Amazing!! [In reply to] Can't Post

If the other one doesn't work, then try

unclean = unclean.replace(//gi, '\'');


Don't give up!!
http://webstationone.com/test/htmlarea


siadmin
Novice

Aug 2, 2003, 5:20 AM

Post #62 of 169 (6737 views)
Shortcut
Re: [Luis] See the ultimate Word cleaner. Amazing!! [In reply to] Can't Post

Sorry still doesn't seem to work.

Displaying the page it gives me &#65506;&#65408;&#65433; looking at the database directly it gives me &#915; or G or ’ there doesn't seen to be a regular occurance of this.

Have put all of the above into the .js file replacing the ' within unclean = unclean.replace(//gi, '\'');


QUIET! I can't hear you and the little voice in my head at the same time. Crazy


siadmin
Novice

Aug 2, 2003, 7:34 AM

Post #63 of 169 (6731 views)
Shortcut
Re: [siadmin] See the ultimate Word cleaner. Amazing!! [In reply to] Can't Post

If anyone is interested, I manged to get around this problem using a ColdFusion tag, not sure if it is just ColdFusion that has experienced this. Here is what I did:

Used to replace the Apostrophe generated by Word to a chr value
<cfset details = REReplace("#form.details#", "#chr(226)##chr(128)##chr(153)#", "#chr(39)#", "ALL")>

Used to replace another type of Apostrophe generated by Word to a chr value
<cfset details = REReplace("#details#", "#chr(226)##chr(128)##chr(152)#", "#chr(39)#", "ALL")>

Used to replace the hyphen generated by Word to a chr value
<cfset details = REReplace("#details#", "#chr(226)##chr(128)##chr(147)#", "#chr(45)#", "ALL")>


QUIET! I can't hear you and the little voice in my head at the same time. Crazy


philps
New User

Aug 7, 2003, 2:45 PM

Post #64 of 169 (6677 views)
Shortcut
Trouble replacing original editor.js with "modded" [In reply to] Can't Post

Luis,
I've replaced the original htmlArea with the one provided at your website as of July 27th. With your editor.js, the <textarea> value is no longer set. I can use the editor normally, but when I submit the form, the <textarea> is blank. Have you (or anybody else) ever experienced that? If not, do you have an idea of what may be causing that?
Thanks,
Felipe

Life's a cabaret.


Luis
Veteran

Aug 7, 2003, 5:04 PM

Post #65 of 169 (6670 views)
Shortcut
Re: [philps] Trouble replacing original editor.js with "modded" [In reply to] Can't Post

Hi Philips:

I don't get it right. Is there a place where I can see your implementation working? If you don't want to make your url public send me a PM with it or attach your files to take a look.

Greetings


Don't give up!!
http://webstationone.com/test/htmlarea


geroreilly
Novice

Aug 7, 2003, 9:07 PM

Post #66 of 169 (6660 views)
Shortcut
Re: [Luis] See the ultimate Word cleaner. Amazing!! [In reply to] Can't Post

Luis,
This is some brilliant work and really appreciated. I read a previous post saying that you werent interested in any donations!... So there really are some genuine nice guys left! Thanks

Of course, after all that flattery I have a request that you may be able to help me with. I am using your editor.js and am having a problem with anchor tags - when I create a new Anchor and when I open a Word Document in the HTML Area. It always puts the link as the full URL that is currently being used. However, I have an edit page and a viewing page so when the viewer opens the page and clicks on an anchor link it will bring them to the edit page rather than staying in the viewer page.

I saw something in your editor.js file and played around with the syntax many many times but couldnt get it to work.

I also posted this on the HTML area section as follows which may help explain some more.....
Hello,
I am using the WebStation version of htmlArea from Luis and have almost =
everything working OK except for Anchor links within a page.

I have tried using the unclean script as referred to in the editor.js =
but it still doesnt work. The code I used was :
unclean =3D =
unclean.replace(/http\:\/\/intranet\/cgi-bin\/vdc2_kb\/WService=3Dkb_dev\=
/kb\/portal\/src\/Admin\MaintDetail?/gi, ' ');=20

The URL in the browser is =
http://intranet/cgi-bin/vdc2_kb/WService=3Dkb_dev/kb/portal/src/Admin/Mai=
ntDetail?cArticleID=3DdmpiOCTq9S78231682&cArticleNumber=3D100007 but the =
ArticleID and ArticleNumber change all the time.

The MaintDetail page is where Admins update content but viewers actually =
view it through a different URL. Therefore, using the obsolute url is =
not what I want to do in this case.

In the editor if I just type http://intranet/test.html it appears OK. =
BUt if I type in #testing then the href used is:
http://intranet/cgi-bin/vdc2_kb/WService=3Dkb_dev/kb/portal/src/Admin/Mai=
ntDetail?cArticleID=3DdmpiOCTq9S78231682&amp;cArticleNumber=3D100007#test=
whereas I just want #test so that the link stays within the same =
document..... relative link.

Any idea how I can achieve this result?

Thanks again in advance and thanks for all this great effort....


Luis
Veteran

Aug 7, 2003, 9:34 PM

Post #67 of 169 (6658 views)
Shortcut
Re: [geroreilly] See the ultimate Word cleaner. Amazing!! [In reply to] Can't Post

Hi geroreilly:

When this strange change occurs in the code? while you are in the editor and switch to HTMLView, or just after submitting the form?

Anyway, the code here is very confusing. It seems to me that your browser is encoding special characters like &.

Could you send me a clean original URL of one of your articles. the ones included in your message seems to be corrupted with = signs that I don't know if belong or not to the url. the dynamic articles ID and Name could be a problem, but I think It's achievable.

Greetings.


Don't give up!!
http://webstationone.com/test/htmlarea


Rorrah
Novice

Aug 11, 2003, 7:26 PM

Post #68 of 169 (6618 views)
Shortcut
Re: [Luis] See the ultimate Word cleaner. Amazing!! [In reply to] Can't Post

I managed to get a little overzealous in my customizations of the cleanhtml area of the script. It wasn't managing to catch all the variations of crap that Word could put after the <p> tag. So I ended up doing thing

/<p[^>]*>/gi '<p>'

Which works wonderfully...except I just realized I've killed the ability of my users to center text. One of the few things I was actually allowing them to do. So I need to find a way to kill ALL attributes inside the <p> tag except align. My regex subexpressions skills aren't up for this one tho. Can anyone help?


Luis
Veteran

Aug 11, 2003, 8:33 PM

Post #69 of 169 (6616 views)
Shortcut
Re: [Rorrah] See the ultimate Word cleaner. Amazing!! [In reply to] Can't Post

Hi Rorrah:

Actually, the function that takes care of it is not in the function cleanHTML(unclean), but the function myclean(editdoc), where the approach is quite different and you don't need to make any replacement or use regex.

Download my editor from the url below. I made some changes to improve the cleanup functions. The cleanHTML(unclean) got reduced substantially. In addition, I added a sort of Word's detection, so class and style attributes get cleared only when pasted contents come from Word while keeping them when those attributes are manually inserted or come from another sources.

The other parts affected are:

else if (cmdID.toLowerCase() == 'paste') .....

if (ctrlKey && (ord == 86) ...... and

if (ctrlKey && (ord == 45)


Don't give up!!
http://webstationone.com/test/htmlarea


Rorrah
Novice

Aug 11, 2003, 8:46 PM

Post #70 of 169 (6611 views)
Shortcut
Re: [Luis] See the ultimate Word cleaner. Amazing!! [In reply to] Can't Post

Oh...well thats where I run into trouble. See I'm using the newer version of editor, as at least half of the people who are using this seem to be using Mac's. (Old mac's no less, evil evil things) So I actually pulled out your code and put it into something independent of the editor. Basically I pull the text from the DB, clean it and put it back in. Not the most efficient, but works with my skill set and doesn't freak out at all. Unfortuantly when I did that, I couldn't get the myclean part of it to work. It threw errors all over the place.

So I managed to get most of what I needed back into the cleanhtml part of it. So I'm back to how do I pull out everything but align= from the <p> tags


Luis
Veteran

Aug 11, 2003, 8:55 PM

Post #71 of 169 (6612 views)
Shortcut
Re: [Rorrah] See the ultimate Word cleaner. Amazing!! [In reply to] Can't Post

Hi again Rorrah:

I'm sorry. I wrongly assumed your posting was regarding Version 2. As you talk about Mac, I guess you are using Version 3, such a case my mods won't work. I apologize for the confussion.

Regarding your original question, my "gray matter" is not enough to figure out how to achieve it.

Once again, I'm sorry.


Don't give up!!
http://webstationone.com/test/htmlarea


Rorrah
Novice

Aug 11, 2003, 9:02 PM

Post #72 of 169 (6610 views)
Shortcut
Re: [Luis] See the ultimate Word cleaner. Amazing!! [In reply to] Can't Post

Thats okay...like I said. I'm using part of it after the fact.

So I just need to incorporate all the cleaning into the cleanHTML part of the code and it works great.



So does anyone know regex enough to offer a suggestion.


Luis
Veteran

Aug 12, 2003, 2:38 AM

Post #73 of 169 (6606 views)
Shortcut
Re: [Luis] See the ultimate Word cleaner. Amazing!! [In reply to] Can't Post

Hi again Rorrah:

I managed to do it using three expressions. Hope this helps.

(/<P [^>]*align/gi, "<p align");
(/<P class[^>]*>/gi, "<p>");
(/<P style[^>]*>/gi, "<p>");


Don't give up!!
http://webstationone.com/test/htmlarea


geroreilly
Novice

Aug 13, 2003, 10:46 PM

Post #74 of 169 (6531 views)
Shortcut
Re: [Luis] See the ultimate Word cleaner. Amazing!! [In reply to] Can't Post

Luis,

Thanks for replying. It was the Queens birthday here in Thailand so they gave us a few days off work!

When I insert an anchor link using the link option and switch to the HTML View it already puts the complete URL in the ahref - thats before I submit my form.

Yes the last example I gave you had many = (equals) which were just a result of a copy paste. The complete correct URL for example is http://katie/cgi-bin/katie/WService=ws_katie/kb/portal/src/Admin/MaintDetail.html?ArticleID=IFX234345435GHTY ( so the only equals signs are WService=ws_katie and ArticleID=IFX).

Instead of the editor putting the complete URL as the ahref I would like to be able to link to an anchor on the same page. Example, <ahref="#anchortag">go to anchor tag </a> instead of the complete URL in the ahref.

Obviously the Article ID's can change so I need to consider that.....

I hope you can come up with a solution for me.......

If you need any further info please let me know.


Luis
Veteran

Aug 14, 2003, 12:05 AM

Post #75 of 169 (6527 views)
Shortcut
Re: [geroreilly] See the ultimate Word cleaner. Amazing!! [In reply to] Can't Post

Hi geroreilly:

I have only two questions to clarify and make it bullet-proof.

1.- Is Article Id the only variable part?

2.- Is some other part of the URL likely to appear somewhere else in an article besides the anchor tags, which you wouldn't need to be removed, for example a link or reference to another page that matches part ot he Url? If so, which part?

I can anticipate it's achiveable, all I need is this information.

I expect for your answer.
Greetings.


Don't give up!!
http://webstationone.com/test/htmlarea

First page Previous page 1 2 3 4 5 6 7 Next page Last page  View All
 
 


Search for (options)