htmlArea

A directory of browser-based WYSIWYG editors

  MAIN
INDEX
SEARCH
POSTS
WHO'S
ONLINE
LOG
IN

Home: htmlArea 2: htmlArea 2 & 3 archive (read only): htmlArea v2.0:
HTML WYSIWYG startup in HTML source <>


The htmlArea 2 & 3 editors have been discontinued.

We've made these forums available as a read-only reference and knowledge-base for people using or developing editors based on htmlArea 2 or 3.

Anyone who is interested in taking over version 2 or 3 is free to do so. All we ask is that you choose a new name that doesn't have "htmlarea" in it to avoid confusion with this site. We'll even give you a link in the directory to make it easier for people to find you. If you are developing or hosting an htmlArea based-editor under a new name, please submit it to our directory.

 


Roberto
Novice

Dec 18, 2004, 4:41 AM

Post #1 of 5 (1714 views)
Shortcut
HTML WYSIWYG startup in HTML source <> Can't Post

Hi,

I have a problem with te htmlarea.
A have some scripts that i must look in the source <> Because it is setting itself in the page.
"Hello good morning" is then setting hard in the htmlsource when i look on the WYSIWYG editor. It is setting this word hard every time when i making a edit to the page also must the script put again and the words good morning / night deleted.

So, is there a option to start up the htmlarea in source mode instead of the WYSIWYG mode.
Hope that someone can help.



Greetings and a good Xmas
Roberto


jonnyl
Novice

Dec 18, 2004, 4:54 AM

Post #2 of 5 (1711 views)
Shortcut
Re: [Roberto] HTML WYSIWYG startup in HTML source <> [In reply to] Can't Post

In editor.js find the line:

editor_setmode(objname, 'init');

after, add the line:
editor_setmode(objname, 'textmode');

That should do it.


Roberto
Novice

Dec 19, 2004, 3:17 PM

Post #3 of 5 (1697 views)
Shortcut
Re: [jonnyl] HTML WYSIWYG startup in HTML source <> [In reply to] Can't Post

Hi Jonnyl.

I try this but it is not working.

When i do the change in editor.js i don't see text on the page in the editor anymore.
I see the editor fine but the button is not setting automatic to textmode and also nothing anymore to see
What is wrong?

Thanks for helps by the way

Roberto


jonnyl
Novice

Dec 20, 2004, 6:39 AM

Post #4 of 5 (1674 views)
Shortcut
Re: [Roberto] HTML WYSIWYG startup in HTML source <> [In reply to] Can't Post

This is how it looks in my editor.js if I want to start in textmode. Works fine for me. Attach your editor.js and I'll take a look.


Code
// convert htmlarea from textarea to wysiwyg editor 
editor_setmode(objname, 'init');
// Start in textmode
editor_setmode(objname, 'textmode');



Roberto
Novice

Dec 21, 2004, 5:12 AM

Post #5 of 5 (1657 views)
Shortcut
Re: [jonnyl] HTML WYSIWYG startup in HTML source <> [In reply to] Can't Post

Hi jonnyl,

I attach my original here.
editor_setmode(objname, 'textmode'); was not working. Don't no wy
I use it with Article Manager.

When the textmode ( sourcemode) is working i also want a word filter in it. But i think that is done in version 3? Im not a hero with this stuff :-(


Thanks for help
Attachments: editor.js (46.7 KB)

 
 
 


Search for (options)