A directory of browser-based WYSIWYG editors


Home: htmlArea 3 (beta): htmlArea 2 & 3 archive (read only): htmlArea v3.0 - Discussion:
Firefox 1.0 on linu popup problem

The htmlArea 2 & 3 editors have been discontinued.

We've made these forums available as a read-only reference and knowledge-base for people using or developing editors based on htmlArea 2 or 3.

Anyone who is interested in taking over version 2 or 3 is free to do so. All we ask is that you choose a new name that doesn't have "htmlarea" in it to avoid confusion with this site. We'll even give you a link in the directory to make it easier for people to find you. If you are developing or hosting an htmlArea based-editor under a new name, please submit it to our directory.


New User

Nov 15, 2004, 10:04 AM

Post #1 of 3 (3285 views)
Firefox 1.0 on linu popup problem Can't Post

I have both Firefox .9.1 and 1.0 on Suse 9 Professional. The popups work perfect on .9.1 for the color pickers. However the popups for the color pickers do not show up at all on Firefox 1.0 for linux. I have made sure that popups are enabled on the site in question. They do show up for Firefox 1.0 on Windows 2000 service pack 4. The only error I see in the javascript consol is

Error: [Exception... "'Permission denied to get property Window.Dialog' when calling method: [nsIDOMEventListener::handleEvent]" nsresult: "0x8057001e (NS_ERROR_XPC_JS_THREW_STRING)" location: "<unknown>" data: no]

New User

Nov 30, 2004, 11:56 PM

Post #2 of 3 (3140 views)
Re: [tvmaly] Firefox 1.0 on linu popup problem [In reply to] Can't Post

I use Fedora, Core release 1. and Firefox 1.0 and latest stable HTMLArea 3 and everything works fine here. Maby a local problem ?

Also for ppl useing Firefox, please read this:

Setting Prefs for the Mozilla Rich Text Editing Demo

To protect users' private information, unprivileged scripts cannot invoke the Cut, Copy, and Paste commands in the Mozilla rich text editor, so the corresponding buttons on the Mozilla Rich Text Editing demo page will not work. To enable these functions for purposes of the demo, you must modify your browser preferences.

1. Quit Mozilla. If you have Quick Launch running (in Windows, an icon in the toolbar), quit that too.
2. Find your Mozilla profile directory. On Windows, this is often located in

c://WINNT/Profiles/<your Windows login>/Application Data/Mozilla.
3. Open the user.js file from that directory in a text editor. If there's no user.js file, create one.
4. Add these lines to user.js:

user_pref("capability.policy.policynames", "allowclipboard");
user_pref("capability.policy.allowclipboard.sites", "");
user_pref("capability.policy.allowclipboard.Clipboard.cutcopy", "allAccess");
user_pref("capability.policy.allowclipboard.Clipboard.paste", "allAccess");
5. Save the file, and restart Mozilla. The Clipboard buttons should now function.


Feb 1, 2005, 6:05 PM

Post #3 of 3 (2704 views)
Re: [crysys] Firefox 1.0 on linu popup problem [In reply to] Can't Post

I've run into this problem a couple times. I'm a Linux/Mac user. Last time I used Windows in any real way was Windows '98. So these generalized instructions for NT doesn't really help.

It's not like you can search for user.js as it isn't often there. Anyways, this was really good:

Windows 2000/Windows XP
C:\Documents and Settings\user_name\Application Data\Mozilla\Profiles\profilename\xxxxxxxx.slt
NOTE: These files are hidden by default.
To see hidden files:
1. On the Tools menu in Windows Explorer, click Folder Options
2. Click the View tab
3. Under Hidden files and folders, click Show hidden files and folders

Windows 98
C:\Windows\Application Data\Mozilla\Profiles\profilename\xxxxxxxx.slt

Windows NT
C:\Winnt\Profiles\user_name\Application Data\Mozilla\Profiles\profilename\xxxxxxxx.slt

Windows ME
C:\Windows\Application Data\Mozilla\Profiles\profilename\xxxxxxxx.slt

Windows 95


Search for (options)