htmlArea

A directory of browser-based WYSIWYG editors

  MAIN
INDEX
SEARCH
POSTS
WHO'S
ONLINE
LOG
IN

Home: htmlArea 3 (beta): htmlArea 2 & 3 archive (read only): htmlArea v3.0 - Bug Reports & Fixes:
tables and a vertical bar...


The htmlArea 2 & 3 editors have been discontinued.

We've made these forums available as a read-only reference and knowledge-base for people using or developing editors based on htmlArea 2 or 3.

Anyone who is interested in taking over version 2 or 3 is free to do so. All we ask is that you choose a new name that doesn't have "htmlarea" in it to avoid confusion with this site. We'll even give you a link in the directory to make it easier for people to find you. If you are developing or hosting an htmlArea based-editor under a new name, please submit it to our directory.

 


WeBoat
New User

Feb 9, 2005, 6:23 PM

Post #1 of 1 (1842 views)
Shortcut
tables and a vertical bar... Can't Post

Using the following code:



<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">

<html>
<head>
<title>Compose test</title>
</head>

<!---- Set up the HTML Area ---->
<script type="text/javascript">
_editor_url = "/common/htmlarea3/";
_editor_lang = "en";
</script>

<script type="text/javascript" src="/common/htmlarea3/htmlarea.js"></script>

<script type="text/javascript">
var editor = null;
function initEditor() {
editor = new HTMLArea("composeText");

// comment the following two lines to see how customization works
editor.generate();
return false;

}
</script>


<body id="composeWindow" bgcolor="#ffffcc"
onload="HTMLArea.init();HTMLArea.onload = initEditor;"
topmargin="0" bottommargin="0" leftmargin="5" rightmargin="5" scroll="no" >



<table id="editTable" cellpadding="0" cellspacing="0" style="width:100%;height:450">
<tr>
<td>
<form action="" id="composeForm" name="composeForm">
<textarea id="composeText" name="composeText" style="width:100%" rows="20" cols="80">
</textarea>
</form>
</td>
</tr>
</table>



</body>
</html>




If I have the textarea inside the table. I'm getting about 8 vertical bars scattered randomly on the first three lines of the htmlarea. If I remove the textarea from the table everything is fine. I'm new to htmlarea, but I would think this is a bug in the beta 3 code. I am attaching a jpg of the bars when it is in the table.

Using IE6.
Attachments: htmlarea.jpg (5.56 KB)

 
 
 


Search for (options)