htmlArea

A directory of browser-based WYSIWYG editors

  MAIN
INDEX
SEARCH
POSTS
WHO'S
ONLINE
LOG
IN

Home: htmlArea 3 (beta): htmlArea 2 & 3 archive (read only): htmlArea v3.0 - Add-Ons:
HTMLArea SpellCheck dictionary problem solved


The htmlArea 2 & 3 editors have been discontinued.

We've made these forums available as a read-only reference and knowledge-base for people using or developing editors based on htmlArea 2 or 3.

Anyone who is interested in taking over version 2 or 3 is free to do so. All we ask is that you choose a new name that doesn't have "htmlarea" in it to avoid confusion with this site. We'll even give you a link in the directory to make it easier for people to find you. If you are developing or hosting an htmlArea based-editor under a new name, please submit it to our directory.

 


bblakley
Novice

Aug 21, 2004, 12:04 PM

Post #1 of 3 (6669 views)
Shortcut
HTMLArea SpellCheck dictionary problem solved Can't Post

OK, I had the same problem that a lot of folks seemed to have, which is to say that I got everything installed and working, but no dictionaries were in the pulldown list, and hence, every word was flagged as mis-spelled. Mad

I finally wrote a little script that helped me solve the problem:


Quote
use Text::Aspell;
$speller = Text::Aspell->new;
if ($speller) {
print "Your dictionaries are:\n";
@dicts = $speller->list_dictionaries;
if ($#dicts < 0) {
print " No dictionaries found.\n\n";
} else {
foreach $i (@dicts) {
print "$i\n";
}
print "\n";
}
print "Your configuration dump:\n";
$speller->print_config;
} else {
print "Could not create new speller. Exiting.\n";
}


You need to run this from a command line, and using the "|more" option might be a good idea.

As expected, Text::Aspell wasn't finding any dictionaries even though the Aspell executable found them no problem (aspell.exe dump dicts). In the config dump however, was (among other interesting lines) this one:


Quote
master-path: C:/Perl/dict/


as well as several others.

So, I created c:\perl\dict and c:\perl\data and copied c:\progra~1\aspell\dict and c:\progra~1\aspell\data respectively, and voila - everything works. Now I just need to figure out how to change the config of Text::Aspell to look at c:\progra~1\aspell\dict and data and I'll have a clean working implementation.


ozinm
User

Oct 14, 2004, 7:04 AM

Post #2 of 3 (6535 views)
Shortcut
Re: [bblakley] HTMLArea SpellCheck dictionary problem solved [In reply to] Can't Post

Hi ya,

Thanks for putting this together!! Finally got the spell checker workingSmile!

As you can see from the output of your script below - it's well worth actually runnig your script as I needed to copy the data & dict folders to C:/Perl/site/lib/auto/Text/As/

If anyone is unsure how to do this, copy bblakley's script text (above) paste it into a text file and save it as c:\1.pl

from the command line type:

c:\1.pl > c:\1.txt

you can then use notepad to read c:\1.txt for your results.



Here's wahat my dump looked like:


Code
   



Your dictionaries are:
No dictionaries found.

Your configuration dump:
actual-dict-dir: C:/Perl/site/lib/auto/Text/As/dict/
actual-lang: en
conf: aspell.conf
conf-dir: C:/Perl/site/lib/auto/Text/As/
conf-path: C:/Perl/site/lib/auto/Text/As//aspell.conf
data-dir: C:/Perl/site/lib/auto/Text/As/data
dict-dir: C:/Perl/site/lib/auto/Text/As/dict
encoding: iso8859-1
filter: url
mode: url
extra-dicts:
home-dir: C:/Perl/site/lib/auto/Text/As
ignore: 1
ignore-accents: false
ignore-case: false
ignore-repl: false
jargon:
keyboard: standard
lang: en_US
language-tag: en_US
local-data-dir: C:/Perl/site/lib/auto/Text/As/dict/
master:
master-flags:
master-path: C:/Perl/site/lib/auto/Text/As/dict/
module: default
module-search-order:
per-conf: .aspell.conf
per-conf-path: C:/Perl/site/lib/auto/Text/As/.aspell.conf
personal: en.pws
personal-path: C:/Perl/site/lib/auto/Text/As/en.pws
prefix: C:/Perl/site/lib/auto/Text/As
repl: en.prepl
repl-path: C:/Perl/site/lib/auto/Text/As/en.prepl
run-together: false
run-together-limit: 8
run-together-min: 3
run-together-specified: false
save-repl: true
set-prefix: true
size: +60
spelling:
strip-accents: false
sug-mode: normal
word-list-path: C:/Perl/site/lib/auto/Text/As/data
backup: true
reverse: false
time: false
keymapping: aspell
fm-email: url,email
fm-none:
fm-sgml: url,sgml
fm-tex: url,tex
fm-url: url
email-quote: >,|
email-margin: 10
tex-command: addtocounter pp,addtolength pp,alpha p,arabic p,fnsymbol p,roman p,stepcounter p,setcounter pp,usecounter p,value p,newcounter po,refstepcounter p,label p,pageref p,ref p,newcommand poOP,renewcommand poOP,newenvironment poOPP,renewenvironment poOPP,newtheorem poPo,newfont pp,documentclass op,usepackage op,begin po,end p,setlength pp,addtolength pp,settowidth pp,settodepth pp,settoheight pp,enlargethispage p,hyphenation p,pagenumbering p,pagestyle p,addvspace p,framebox ooP,hspace p,vspace p,makebox ooP,parbox ooopP,raisebox pooP,rule opp,sbox pO,savebox pooP,usebox p,include p,includeonly p,input p,addcontentsline ppP,addtocontents pP,fontencoding p,fontfamily p,fontseries p,fontshape p,fontsize pp,usefont pppp,documentstyle op,cite p,nocite p,psfig p,selectlanguage p,includegraphics op,bibitem op,geometry p,
tex-check-comments: false
tex-extension: tex
sgml-check: alt
sgml-extension: html,htm,php,sgml



cubic
New User

Nov 29, 2004, 7:27 PM

Post #3 of 3 (6222 views)
Shortcut
Re: [ozinm] HTMLArea SpellCheck dictionary problem solved [In reply to] Can't Post

Hi ozinm,

Thanks for the info, thought I'd contribute another option that worked for me (sorry if it's already on another thread somewhere):

Install perl module, aspell and dictionary as instructed.
Don't move or copy the aspell-15.dll file anywhere else (if you've already copied it to your perl directory then delete or disable it there).
Instead add the aspell binary directory to your windows path (default is c:\progra~1\aspell\bin)
Depending on your system you may need to reboot to get perl to see the new path.

Your config dump program confirms:
actual-dict-dir: c:/progra~1/aspell/dict/

cubic

 
 
 


Search for (options)